如何使用ACD指标 ACD升降线指标详解 ACD指标公式源码

炒股入门知识 zhaojg5 1周前 (11-18) 2次浏览 已收录 0个评论

其实,在股票术语中,ACD指标就是指ACD升降线,主要是用来分析收盘价与最高、最低价之间的涨跌关系变化的技术指标,但是在实战中应该如何使用ACD指标,ACD升降线指标怎样用,ACD指标公式的源码是如何的,下面我们居北海股票学习网分析师将会对ACD指标的相关知识进行总结分析。

ACD升降线指标

在进行ACD指标的使用之前,应该了解ACD升降线指标的原理,主要是包含3个方面的内容:

1、如果当天的收盘价高于昨天的收盘价,那么收集力量等于当天收盘价与真实价位之间的差值;而真实低位是当天低位与昨天收盘价两者中的最低者;

2、如果是当天的收盘价低于昨天的收盘价,派发的力量就等于当天真实高位与当天收盘价之间的差值,而真实高位是当天高位与昨天收盘价中比较高的;

3、将收集力量与派发力量相加,就可以得到市场的净收集力量,目前是了解市场的强弱变化;

如何使用ACD指标

在了解了基本的指标原理之后,投资者有必要学习如何使用ACD指标,那么最基础的就是其研判原则与应用法则:

(1)当ACD线下降,而股价处于上升阶段的时候,是卖出的信号;

(2)如果ACD线上升,股价反而出现了下跌的情况,是买进的信号;

(3)当然ACD线也不完全是单独使用的,如果结合均线指标进行分析,当ACD指标向上穿越20日线的时候,是买点;

(4)ACD指标向下穿过20日线,是卖出位置;

具体的走势形态如图000045在2010年12月24日的日线图变化,在对应的ACD指标中,白ACD向下穿过了黄色MAACD线,并且当天的股价走势下跌了将近7.46%,形成了一根大阴线,并且击穿了多根均线,形成的是断头铡刀的K线组合形态,预示着下跌的行情,必须要及时的卖出逃跑。

ACD指标公式

其实升降线是有计算公式的,而其最佳的参数是设置在20,M=20,具体的公式如下:

①LC=昨日收盘价;

②dif=收盘价-假设收盘价>LC,返回最低价和LC的较小值,否则返回最高价和LC的较大值;

③ACD=dif历史累计和,如果收盘价=LC,则ACD=0;

④MAACD=ACD的M日指数平滑移动平均。

但是不同的是acd指标还有一定的源码公式:

顶:=BBI+3*STD(BBI,13),COLOR004AFF;

底:=BBI-3*STD(BBI,13),COLOR67FF00;

DRAWBAND(BBI,RGB(97,95,00),顶,RGB(97,95,00));

DRAWBAND(BBI,RGB(25,75,150),底,RGB(25,75,250));

A:=CURRBARSCOUNT;

A1:=DAY!=REF(DAY,1);

A2:=BARSLAST(A1)+1;

A3:=REF(IF(A2=1,1,A2),A2);

A4:=CONST(REF(HHV(H,A3),A2));

A5:=CONST(REF(LLV(L,A3),A2));

A6:=MA(AMO,A3)/MA(VOL,A3)/100;

A7:=REF(MA((H+L+C)/3,A3),A2);

中枢价格:=IF(CAPITAL>0,REF(A6,A2),A7);

均价:=(A4+A5)/2;

价差:=ABS(中枢价格-均价);

中枢价格区上沿:IF(A<=CONST(A2),(中枢价格+价差),DRAWNULL);

中枢价格区下沿:IF(A<=CONST(A2),(中枢价格-价差),DRAWNULL);

DRAWBAND(中枢价格区上沿,RGB(155,50,50),中枢价格区下沿,RGB(155,50,50));

开盘价幅上线:IF(A<=CONST(A2),(REF(HHV(H,1),A2-1)),DRAWNULL);

开盘价幅下线:IF(A<=CONST(A2),(REF(LLV(L,1),A2-1)),DRAWNULL);

HH0:=CONST(HHV(H,120))*1;

LL0:=CONST(LLV(L,120))*1;

MM0:=CONST((HH0+LL0)/2);

HH1:=IF(CONST(C)

LL1:=LL0;HLMAX:=MAX(HH1,LL1);

HLMIN:=MIN(HH1,LL1);

HLMN1:=(HLMAX+HLMIN)/2;

HLMN2:=(HLMAX-HLMIN);

HLMN3:=HHV(V,250)/2;

HLMN4:=HHV(V,250);

VZ:=(V-HLMN3)*HLMN2/HLMN4+HLMN1;

预测量:IF(CURRBARSCOUNT=1 AND PERIOD=5,VOL*240/FROMOPEN,VOL),COLOR990000,NODRAW;

STICKLINE(CURRBARSCOUNT=1 AND PERIOD=5,(0-HLMN3)*HLMN2/HLMN4+HLMN1,(预测量-HLMN3)*HLMN2/HLMN4+HLMN1,2,-1),COLORLIGRAY;

STICKLINE(C>=O,VZ,(0-HLMN3)*HLMN2/HLMN4+HLMN1,1,1),COLOR000099;

STICKLINE(C

(MA(V,5)-HLMN3)*HLMN2/HLMN4+HLMN1,COLORFFFFFF;

(MA(V,10)-HLMN3)*HLMN2/HLMN4+HLMN1,COLOR00FFFF;

STICKLINE(CLOSE> REF(CLOSE,1) ,HIGH,LOW,0,1 ),COLORRED;

STICKLINE(CLOSE> REF(CLOSE,1) ,OPEN,CLOSE,3,0 ),COLOR000055;

STICKLINE(CLOSE> REF(CLOSE,1) ,OPEN,CLOSE,2.7,0 ),COLOR000077;

STICKLINE(CLOSE> REF(CLOSE,1) ,OPEN,CLOSE,2.1,0 ),COLOR000099;

STICKLINE(CLOSE> REF(CLOSE,1) ,OPEN,CLOSE,1.5,0 ),COLOR0000BB;

STICKLINE(CLOSE> REF(CLOSE,1) ,OPEN,CLOSE,0.9,0 ),COLOR0000DD;

STICKLINE(CLOSE> REF(CLOSE,1) ,OPEN,CLOSE,0.3,0 ),COLOR0000FF;

STICKLINE(CLOSE= REF(CLOSE,1) ,HIGH,LOW,0,1 ),COLORWHITE;

STICKLINE(CLOSE= REF(CLOSE,1) ,OPEN,CLOSE,3,0 ),COLOR555555;

STICKLINE(CLOSE= REF(CLOSE,1) ,OPEN,CLOSE,2.7,0 ),COLOR777777;

STICKLINE(CLOSE= REF(CLOSE,1) ,OPEN,CLOSE,2.1,0 ),COLOR999999;

STICKLINE(CLOSE= REF(CLOSE,1) ,OPEN,CLOSE,1.5,0 ),COLORBBBBBB;

STICKLINE(CLOSE= REF(CLOSE,1) ,OPEN,CLOSE,0.9,0 ),COLORDDDDDD;

STICKLINE(CLOSE= REF(CLOSE,1) ,OPEN,CLOSE,0.3,0 ),COLORFFFFFF;

STICKLINE(CLOSE< REF(CLOSE,1) ,HIGH,LOW,0,1 ),COLORCYAN;

STICKLINE(CLOSE< REF(CLOSE,1) ,OPEN,CLOSE,3,0 ),COLOR990000;

STICKLINE(CLOSE< REF(CLOSE,1) ,OPEN,CLOSE,2.7,0 ),COLORCC0000;

STICKLINE(CLOSE< REF(CLOSE,1) ,OPEN,CLOSE,2.1,0 ),COLORFF4400;

STICKLINE(CLOSE< REF(CLOSE,1) ,OPEN,CLOSE,1.5,0 ),COLORFF8800;

STICKLINE(CLOSE< REF(CLOSE,1) ,OPEN,CLOSE,0.9,0 ),COLORFFCC00;

STICKLINE(CLOSE< REF(CLOSE,1) ,OPEN,CLOSE,0.3,0 ),COLORCYAN;

通过顶底变化,以及预测量和中枢价格的变化进行分析,具体的实战案例如图飞亚达A的日K线走势,从最低点11.09元上涨到19.47元,在中枢价格的区间内变化,希望投资者能够积极的把握其中的操作机会。

以上就是本文讲解了ACD升降线指标的基本概念原理以及如何使用ACD指标和 ACD指标公式的源码形态,如果您还想要了解更加专业的技术指标形态,请点击OX图如何分析

喜欢 (0)
[]
分享 (0)
发表我的评论
取消评论
表情 贴图 加粗 删除线 居中 斜体 签到

Hi,您需要填写昵称和邮箱!

  • 昵称 (必填)
  • 邮箱 (必填)
  • 网址